Scolring - Forum

Entraides et échanges autour de la technologie Scol - Informations and exchanges on the Scol technology

Vous pouvez changer la langue de l'interface une fois inscrit - You can change the language once registered

You are not logged in.

#1 19-Jul-2018 07:52:22

frudas24
Member
Registered: 18-Apr-2018
Posts: 19

Android API Level 26 required in August 2018

Hi, on the next month the apk cant be upload to the play store if dont have target api level to 26.
I make some test and change:
C:\Program Files (x86)\Scol Voyager\androidDeployerTools\scolbase\AndroidManifest.xml.in

and compiled an apk with  api level 26 but Openspace3D dont ask for a camera permision. sad


Source:
https://android-developers.googleblog.c … mance.html

pd: In August 2019, Play will require that new apps and app updates with native libraries provide 64-bit versions in addition to their 32-bit versions.

Offline

#2 19-Jul-2018 08:46:02

arkeon
Admin. / Scol language & OpenSpace3D developer
From: Nantes
Registered: 30-Mar-2009
Posts: 4,221
Website

Re: Android API Level 26 required in August 2018

Doh!

I missed that one hmm
Thanks a lot for the reminder ^^, I'm looking in this soon.
Maybe not for the coming release through since it's planned next week...

Offline

#3 19-Jul-2018 15:30:17

arkeon
Admin. / Scol language & OpenSpace3D developer
From: Nantes
Registered: 30-Mar-2009
Posts: 4,221
Website

Re: Android API Level 26 required in August 2018

Well finally it's done for API 26 and permissions request. So it will be in incoming release smile

64Bits version for Android will be obligatory in 2019, since I've a lot of scripts to update and build I'll wait the next release for this.
I'll send you a portable version of OS3D 1.60 with this feature so you will be able to check if all is correct.

Offline

#4 19-Jul-2018 19:59:31

arkeon
Admin. / Scol language & OpenSpace3D developer
From: Nantes
Registered: 30-Mar-2009
Posts: 4,221
Website

Re: Android API Level 26 required in August 2018

link sent in your mail

Offline

#5 20-Jul-2018 18:26:41

frudas24
Member
Registered: 18-Apr-2018
Posts: 19

Re: Android API Level 26 required in August 2018

Men You are a Hero, Thanks so much.

Offline

#6 24-Jul-2018 15:48:51

frudas24
Member
Registered: 18-Apr-2018
Posts: 19

Re: Android API Level 26 required in August 2018

Hi, the update works great for the playstore but the program OS3D get freeze  when started in Loading:target
link to screen capture : Error
some times it load but now is not opening anymore

Last edited by frudas24 (24-Jul-2018 15:49:48)

Offline

#7 24-Jul-2018 18:42:50

arkeon
Admin. / Scol language & OpenSpace3D developer
From: Nantes
Registered: 30-Mar-2009
Posts: 4,221
Website

Re: Android API Level 26 required in August 2018

weird ^^
Did you tried to restart the computer in case the file is used by windows ?

Offline

#8 26-Jul-2018 06:17:20

frudas24
Member
Registered: 18-Apr-2018
Posts: 19

Re: Android API Level 26 required in August 2018

Hi, i Tried in another computer and have the same problem.
at the end what i did to fix the problem was to open partition_LockedApp\tools\os3deditor\os3deditor.scol with OpenSpace3D.exe
and it works!!!
by the way both of them use win10 x64.

Offline

#9 26-Jul-2018 11:54:04

arkeon
Admin. / Scol language & OpenSpace3D developer
From: Nantes
Registered: 30-Mar-2009
Posts: 4,221
Website

Re: Android API Level 26 required in August 2018

strange, I don't understand the issue.
how can I reproduce it ?

Offline

#10 26-Jul-2018 20:54:30

frudas24
Member
Registered: 18-Apr-2018
Posts: 19

Re: Android API Level 26 required in August 2018

Hi, is with the portable version that you sended to my email.
to reproduce: just unzip and open openspace3d.exe

Offline

Board footer

Powered by FluxBB