Scolring - Forum

Entraides et échanges autour de la technologie Scol - Informations and exchanges on the Scol technology

Vous pouvez changer la langue de l'interface une fois inscrit - You can change the language once registered

You are not logged in.

#1 25-Oct-2017 01:01:45

PH1LJ
Member
Registered: 23-Oct-2017
Posts: 4

Issue with Raspberry and no MOUSE

Hi
Not sure if this is right place, but anyway - i have been testing some of the
Samples and at no point do I get a mouse pointer on the screen - the 3D designs
Are present and work with gpio settings.

Hope that makes sense, i'm using the latest build of jessie, not stretch.:o

Offline

#2 25-Oct-2017 06:23:49

arkeon
Admin. / Scol language & OpenSpace3D developer
From: Nantes
Registered: 30-Mar-2009
Posts: 3,979
Website

Re: Issue with Raspberry and no MOUSE

hello,

to get a mouse cursor on RPI you can use the picture plugit, combined with mouse plugit with moves.

Offline

#3 25-Oct-2017 14:52:43

PH1LJ
Member
Registered: 23-Oct-2017
Posts: 4

Re: Issue with Raspberry and no MOUSE

Ok - I tried your suggestion, with both the texture checkbox set / cleared & also the transparency set / cleared on the picture plugit - I do not see the mouse on the RPi

I should also say, I tested it with and without the Mouse cursor visible option set

Do you have a working example ?

Last edited by PH1LJ (25-Oct-2017 14:54:42)

Offline

#4 25-Oct-2017 15:25:48

arkeon
Admin. / Scol language & OpenSpace3D developer
From: Nantes
Registered: 30-Mar-2009
Posts: 3,979
Website

Re: Issue with Raspberry and no MOUSE

Hello,
sorry I respond too fast.

There is no mouse cursor on PI.
You can create a cursor picture and use it on the mouse coordinates to use your own cursor.

for example with a picture like this : https://openclipart.org/image/2400px/sv … purple.png

add a picture plugIT and set the picture and the cursor size you want.

then add the mouse plugIT with links

mouse.MouseMove -> picture cursor.Set position

Offline

#5 25-Oct-2017 16:17:50

PH1LJ
Member
Registered: 23-Oct-2017
Posts: 4

Re: Issue with Raspberry and no MOUSE

Ok - maid some progress, I can now see a blank square, that follows the mouse - I have tried setting the Picture options
as follows, with the bitmap path pointing to the pointer image, you provided :-

Apply on texture, set - seems to blank the square
Apply on texture, clear -

Transparent needs to set - only shows the square.

Note: the Mouse cursor visibilty is shown
Sent parameter = 2D position
Enabled on init

Any further suggestions

Offline

#6 25-Oct-2017 19:33:21

arkeon
Admin. / Scol language & OpenSpace3D developer
From: Nantes
Registered: 30-Mar-2009
Posts: 3,979
Website

Re: Issue with Raspberry and no MOUSE

I don't understand,
did you used the picture plugIT ?
set the size in pixel 32 32
also you can resize the bitmap before you use it you d'ont need a huge cursor bitmap ^^

Offline

#7 25-Oct-2017 21:08:28

PH1LJ
Member
Registered: 23-Oct-2017
Posts: 4

Re: Issue with Raspberry and no MOUSE

Yes, frustrating huh.

I'm using the Picture PlugIT :-

The Bitmap path added.
Picture it is resized to 3 x 3. (32 x 32), way to big for RPi)
Apply on texture is NOT set
Show in background is set
Transparency is not set (doesn't seem to make any difference)
Show on Start is set

In the Mouse PlugIT :-

Cursor visibility = Shown
Sent parameter = 2D position
Enable on init = set

ALL I see is a black square, that actually appears transparent, that moves with mouse - when hover the square over an object the
appropriate Bubble label appears

Hope this helps

would be easier with images yikes

Offline

#8 25-Oct-2017 21:55:56

arkeon
Admin. / Scol language & OpenSpace3D developer
From: Nantes
Registered: 30-Mar-2009
Posts: 3,979
Website

Re: Issue with Raspberry and no MOUSE

disable show in background
and enable transparency

use a 16x16 picture it should be better.

Offline

#9 25-Oct-2017 21:58:41

arkeon
Admin. / Scol language & OpenSpace3D developer
From: Nantes
Registered: 30-Mar-2009
Posts: 3,979
Website

Re: Issue with Raspberry and no MOUSE

This is the picture I use on RPI
http://www.arkeon.be/scol/os3d/cursor.png

Offline

Board footer

Powered by FluxBB